1. MotorhomeFun The best Motorhome Club in the World
     
    Register to remove adverts Register Here

    Welcome to Motorhome Fun

    MotorhomeFun is a large community of motorhome and touring enthusiasts. Our website is the busiest of its kind. It serves as a meeting place for thousands of members who share their knowledge of motorhomes and travel, as well as arrange rallies in the UK, Europe and beyond.

    It's easy to join us and takes just a minute

Fiat Ducato Electrical problems

Discussion in 'TECH/MECH GENERAL' started by injebreck99, Jan 30, 2013.

  1. injebreck99

    injebreck99 Funster

    Joined:
    Dec 5, 2011
    Messages:
    554
    Likes Received:
    315
    Location:
    norfolk
    (2009 Swift Bolero.)
    I have just discovered that the lower dash switches, (hazard, door lock/unlock,rear fog, heated mirrors) are not working, but everything else is, heater fan, cigar lighter etc, plus the door locking switch on the drivers door, and all the lights and indicators work, but not the rear fog lamp. I have not used the M/H lately but has been on EHU all the time.
    I had discovered this morning that both batteries were flat after the habitation service technician left the battery charger switched off, I never turn this off, I turned it on and the EHU soon charged the batteries up OK, but I don't think that this was the cause of my trouble.
    I have checked all the fuses and connections I can see, but nothing amiss, I does not help that my fuseboard diagram in the handbook does not match what's on the M/H.
    Seems strange that all them switches in that group are not working all at the same time, they were OK when I last used it., why are the Hazards not working when the indicators are ??
    Any idea's folks, anyone had the same problem, or is an Auto Electrician called for.:helpsos:
  2. ShiftZZ

    ShiftZZ Funster

    Joined:
    Feb 19, 2008
    Messages:
    18,395
    Likes Received:
    22,929
    Location:
    Leicestershire


    Fiat have a habit of specifying a product and then outsourcing the build to a 3rd party, so the device may work but not all devices will be the same, I hope that makes sense.
    Contacting Fiat will not help either, tried that and got nowhere...

    I had a problem with the temp gauge and eventually had to replace the instrument cluster and ECU, it’s all very complex, CAN Bus etc.
    I eventually got it fixed at BR Cartronics in Leicestershire ( I know it too far from you) but you will need someone who has all the kit.

    Sorry I can’t help anymore.

    I do hope it’s not the cluster, they are an arm and a leg..

    Good luck,,
  3. ScotJimland

    ScotJimland Funster

    Joined:
    Jul 25, 2007
    Messages:
    20,583
    Likes Received:
    9,585
    Location:
    Suffolk coast
    How did you check them ?

    If you only did a visual you may still have a blown fuse.. they can look OK but still be blown..

    Remove each one and check with a meter set to ohms .. or substitute each fuse, (one at a time), with a known good fuse (same rating)

    or..if you have access, test the output of each fuse with a meter set to DCv .. (the neg test probe to earth (chassis))
    Last edited: Jan 30, 2013
  4. injebreck99

    injebreck99 Funster

    Joined:
    Dec 5, 2011
    Messages:
    554
    Likes Received:
    315
    Location:
    norfolk
    But why aren't the Hazards working, I did not think they were fused, also, would the heated mirror switch and the door locking and fog lamp switches be on one fuse ?
  5. ScotJimland

    ScotJimland Funster

    Joined:
    Jul 25, 2007
    Messages:
    20,583
    Likes Received:
    9,585
    Location:
    Suffolk coast
    Hazard relay will be fused, as for the others? I don't know for sure but they may well be on one fuse.. first place to start is to test each and every fuse.. there may be more than one blown..
  6. injebreck99

    injebreck99 Funster

    Joined:
    Dec 5, 2011
    Messages:
    554
    Likes Received:
    315
    Location:
    norfolk
    I have managed to fix the problems with my electrics, just don't ask how. I had already removed the fuses in the dash individually and tested them, all OK. went to start the engine and noticed a slightly slow cranking speed, showing 11.2 volts at the battery, despite being fully charged earlier. Can't remember why, but switchd on the control panel inside and was informed that number 13 fuse was blown on the RCD panel, which it was, replaced that and everything was working !!WTF. Will try again tomorrow to see if gremlins have really disappeared. :Doh:
    1 person likes this.
  7. duane0001

    duane0001 Read Only Funster

    Joined:
    Jan 18, 2013
    Messages:
    629
    Likes Received:
    391
    Location:
    East Coast, North Yorks
    Cab battery

    You can't fully discharge a starter battery without damaging it,
    I reckon a new battery is in order for you mate
    Sorry
    Duane
    1 person likes this.
  8. coldstreamer

    coldstreamer Funster

    Joined:
    Feb 1, 2011
    Messages:
    189
    Likes Received:
    119
    Location:
    Redcar
    coldstreamer

    This thread is very eirie, last week I found my starter battery was down, very hard frost struggled, so bit the bullet... new 'Banner' starter battery.
    They are a bit of a pig on the Ducato, so took it down to my 'tame' Fitter,
    he removed the battery with a struggle, ! What did he find behind, it next to the Bulkhead...... A mouse's Nest!! very cosy and looked very new. removed it cleaned the area and re-fitted the new battery. Very fortunate that there was no 'Mouse' damage. Van fine.
    The van is parked in my Yard on hard standing and is moved regular, except for one week in the snow. Very Lucky.. The old battery has taken and held its charge, now in the reserve box with the rest of the Junk.
    One thing is true... its a lesson learned.
    Best Regards, Mac
    1 person likes this.
  9. injebreck99

    injebreck99 Funster

    Joined:
    Dec 5, 2011
    Messages:
    554
    Likes Received:
    315
    Location:
    norfolk
    I reckon you could be right, I did not realise that the EHU charger was switched off after service, I never turn it off, so it could mean a new battery.
    Haven't been able to check anything today, feeling unwell after a recent operation, will check as soon as I'm able.
  10. magicsurfbus

    magicsurfbus Funster

    Joined:
    Oct 11, 2010
    Messages:
    1,792
    Likes Received:
    1,951
    Location:
    NW England
    Probably worth checking the opposite side of the engine bay, which is the favoured spot of small rodents in my Ducato. Mind you since I started duck-taping bait boxes to the battery and to that round dustbin-shaped thingy on the opposite side it's often a very short stay for them. I usually find the mouse corpses inside the bait boxes - talk about fast-acting.

Share This Page